Online Help System

www.screenconnect.com

PRB-0005: Upgrading causes runtime errors

Modified: 2010/08/12 10:51 by Jake Morgan - Categorized as: Knowledge Base

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1 Symptoms

The server commonly throws an error with a description of (application error occurred on the server) or something similar after installing a software upgrade.

Server Error in '/' Application

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2 Cause

This issue occurs because code changes were most likely made to one or more of the .aspx or .aspx.cs files. These files are sometimes modified by users to tailor their installation. The ScreenConnect install will not upgrade any files that have been modified since they were originally installed. This prevents the software from overwriting customization to the software but does present problems when upgrading.

This can be checked by going to the Program Files and looking at the dates of these specific files to see how they compare with the other files in the folder.

Typical files that might have been changed:

  • Host.aspx
  • Host.aspx.cs
  • Guest.aspx
  • Guest.aspx.cs
  • Default.master
  • Default.master.cs

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3 Resolution

To resolve this problem cut and paste your modified .aspx and .aspx.cs files into a temporary folder and then re-install the software selecting via the Control Panel's Add/Remove Programs selecting Repair. By removing the modified files the software will install cleanly and will work as expected.

After the software is installed the user can then copy and paste over any specific file changes manually. Changes should be made by editing the file NOT copying and replacing the entire file

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4 References